IETF - Mail delivery outage – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
All systems operational
Mail delivery outage
Resolved
Partial outage
Started 6 months ago
Lasted about 17 hours
Affected
Mail Services
Partial outage from 4:00 AM to 9:00 PM
Updates
Resolved
May 27, 2024 at 9:00 PM
Resolved
May 27, 2024 at 9:00 PM
This incident has been resolved.
Investigating
May 27, 2024 at 4:00 AM
Investigating
May 27, 2024 at 4:00 AM
We are currently investigating this incident.